ODOO 安装

ODOO 安装

对初学者而言,ODOO 的安装是横在面前的第一道坎,必须过的。和几年前情况不同,最近几年,ODOO在安装方面已经大幅改进,不需要太专业的技能也能完成安装过程。下面先说说大致的安装过程,有空再补上详细的图片和步骤。

准备工作

1、到ODOO官网找到需要的版本

直接进入 http://nightly.odoo.com/ 下载页面可以省去很多寻找麻烦,这里列出各版本在各操作系统下的安装文件和源代码文件。

2、安装合适的浏览器

ODOO 从7.0开始,放弃传统的客户端,全面使用浏览器访问。由于使用了 HTML5 的标准,所以访问ODOO要求浏览器必须支持HTML5。合格的浏览器包括:ChromeFirefoxSafariIE9+

注意: 1、本文所述内容均在 64 位系统上操作,如果是 32 位系统,个别地方需要作相应的修改。

2、安装完成后,在浏览器网址打开 http://<服务器 IP地址>:8069, 即可访问。不能访问就说明安装有错。

将 ODOO 安装在 Windows 上面

先找到下载文件 ,以最新的 ODOO 10 为例,它的下载地址:http://nightly.odoo.com/10.0/nightly/exe/odoo_10.0.latest.exe

下载妥当,直接点击下载的文件,按照屏幕提示完成安装即可。

这样安装的版本并非源代码版本,用于评估ODOO已经足够,要用于开发的话,还是建议安装 Linux 下的源码版本,或者等待粉刷匠出 ODOO 10 的绿色版本。

将 ODOO 安装在 Ubuntu 上面

无论用于生产环境,还是用于开发和测试环境,我们都建议将ODOO安装在 Linux 环境下,稳定性和性能都能得到保证。

ODOO 官方也给出了安装指令。补充一些官方没提到的内容,这样初学者也能根据指令完成安装。

本文举例用的是 ubuntu 16.04,安装 ODOO 10 版本。

使用 SSH 登录到远程服务器(VPS),或者打开本地方服务器的终端。按如下步骤执行指令:

1、更新系统(碰到问 Y/n的地方,一律 Y,下同)

sudo apt-get update && sudo apt-get upgrade

1-0

2、安装数据库

sudo apt-get install postgresql postgresql-contrib

2-0

3、安装 ODOO

wget -O - https://nightly.odoo.com/odoo.key | apt-key add -
echo "deb http://nightly.odoo.com/10.0/nightly/deb/ ./" >> /etc/apt/sources.list
sudo apt-get update && apt-get install odoo

3-0

4、安装 LESS 主题引擎

sudo apt-get install nodejs npm
sudo npm install -g less
sudo npm install -g less-plugin-clean-css

4-0

5、安装 PDF 生成器 wkhtmltopdf

sudo apt-get install libxrender1 fontconfig xvfb
wget http://download.gna.org/wkhtmltopdf/0.12/0.12.3/wkhtmltox-0.12.3_linux-generic-amd64.tar.xz -P /tmp/
cd /opt/
sudo tar xf /tmp/wkhtmltox-0.12.3_linux-generic-amd64.tar.xz
sudo ln -s /opt/wkhtmltox/bin/wkhtmltopdf /usr/local/bin/wkhtmltopdf

5-0

6、安装 nginx

sudo apt-get install -y nginx

6-1

7、检查是否安装成功

6-0

6-2

6-3

Ubuntu 上一键安装 Odoo8/Odoo9/Odoo10

sudo wget http://zhflash.com/downloads/ubuntu_odoo_inst.sh
sudo chmod +x ubuntu_odoo_inst.sh
sudo ./ubuntu_odoo_inst.sh

odoo-one-key-setup

 

anyShare分享到:

8 一条评论

  1. 还是这个简单

  2. :22 :5432 :80 没有 :8069

  3. echo “deb http://nightly.odoo.com/10.0/nightly/deb/ ./” >> /etc/apt/sources.list

    这段是不是有问题 会把“带入list,导致无法安装。

发表评论

电子邮件地址不会被公开。 必填项已用*标注